Old versions of Surfulater prior to Version 3 will not work with versions of Firefox newer than V3.5. You can either upgrade your version of Surfulater to the latest release, downgrade Firefox to V3.5 or use Internet Explorer.

Note that the Firefox Extension included in Surfulater Version 3.x will not work with Surfulater Version 2.x